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Goals of this document (see blog post for more)
Why Illustrator...

Over figure-scripting?
Over other Adobe softwares like Photoshop or InDesign?
Over PowerPoint?

Where can I find onboarding documents (Raj Lab only)?

How to’s:
How do I find my document formatting settings?

Artboards
Color profile
Raster effects

I want to import this graph/image/object into Illustrator: what should I know?
A couple guidelines for exporting graphs from R/MATLAB to Illustrator
What types of files can Illustrator import and what should I know about them?

What are layers, and why will I grow to love them?
Cool, you’ve convinced me. How do I add layers?
Things you might want to include on a locked background layer

Margin guides
Boxes (as for posters)

How do I move objects between layers?
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Align and Distribute
How do I “paste in place”?
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How do I change my arrow key increment from the default?

Vector graphics: drawing, making, editing
About paths

Anchor points: 2 types
Selection tools in Illustrator: how should I click on my object/part of object of interest?

“Selection tool” : keyboard shortcut “v”
“Direct Selection tool” : keyboard shortcut “a”
Other selection tools

How do I set stroke weight?
I have made axes or some other object with right angles but now it looks like there is a gap at the
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https://twitter.com/cojiberries


I added a line segment but I want an arrow: what now?
My arrowhead by default is ridiculously big when I use my desired stroke weight. How do I change it?
Some notes on transform tools in Illustrator

Scale
Rotation
Reflection
Moving

I have TOO MANY POINTS and it is killing my Illustrator - HELP.
I have a line art drawing that I want to vectorize! How can I do this?

Type/text
What font am I using? How do I change it?
Point type vs area/paragraph type: what’s the difference?

Point type: what Arjun calls “text”:
Area type: what Arjun calls “text box”:

How do I superscript or subscript?
How do I change the formatting of my text, ex. for figure captions?

For some reason, I want to add bullet points/numbering in Illustrator
A very brief overview of colors

How do I edit colors?
I want to match the color of an image I have already: how do I do that?
I want to recolor/edit everything that is of one color/attribute: how?
Illustrator soft-proofing tools for simulating how images will appear to others

Using these tools to simulate how images will look to people with color blindness
Images

How do I add a scale bar?
How do I resize groups of images?

Set W and H numerically when importing sets of similar images
Resize images as a group

Linked versus embedded images
How can I tell whether my images are linked or embedded?
I’ve changed the original image file: how can I update my linked image?
How do I embed a linked image?
How do I relink an embedded image?

I’ve completed the checklist and Arjun likes the figures and now I’m preparing to submit figures to a journal:
what formatting do I need to do?

Works Consulted
Some additional links that may be helpful



Raj Lab checklist for Illustrator final figures
Check document formatting

RGB color (not CMYK)
Raster effects resolution high (300ppi)
Arjun prefers points as units
Artboard: letter size (or scaled to figure needs, ex. half-page)

■ Note that for most journal submissions, each figure should be a standard portrait page
size (8.5”x11”).

Macro level formatting
Margins: minimum 0.5 inches (like this doc)

■ Note: Can mark this with smart guides or shape on a locked lower layer
Are images aligned?
Are my subheading labels conserving negative space (ex. Would it be better to put my
subheading letter within one of my images, i.e., white “D” within the image?)
Are my caption and title (ex. “Supplementary Figure ***) in the same location for all of figures
that are the same size? Typically these are in the top left, “Supplementary Figure 3”, bold in
14pt font. A sample can be found in the Illustrator folder here.

Vector graphics (probably anything that is not text and is not a photo)
Set stroke weight of all axes lines to 0.5 pt. Arrows can have stroke weight up to 2 depending on
size (use your aesthetic judgment).
Do arrowheads look reasonable in size? Can adjust using percentage thing (see below).
Do my graphs have a lot of white space? Can I shrink them?

■ AR note: for many graphs, you can actually shrink them a lot.
Streamline graph ticks: i.e., instead of 0, 5, 10, 15, 20, 25, just do 0, 10, 20.

I have multiple graphs of the same type: are they formatted similarly? I.e. are they aligned and
styled the same way?

Ideally also the same size so that they are comparable. Be careful when exporting from
MATLAB or R, because tick labels can sometimes change the size of the plot. If you can
have MATLAB or R plot them all together, that will often help maintain size.

Type/text
Are you using Helvetica (or something equally legible/reasonable)?
3 font sizes allowed:

14 pt bold for figure subheading letters (A, B, C…)
8 pt for “normal” text (ex. Axes labels) and for figure caption
6 pt for “small” text (ex. Legend labels)
Does your font look bizarrely small? Check if it is superscripted or subscripted

Are your figure legend text boxes left or full justified?
Camera images (microscope photos mostly)

Scale bars on everything.
5µm or 10µm. Scale bar should be a white line (not rectangle). Use camera pixel size
and size of image on Illustrator to help set the length of the line. More details below.

Are images aligned and the same size?
■ MAKE SURE IMAGES ARE THE SAME SIZE. To do this, you can select them and

adjust the size by directly typing in the size in the properties panel.
Did you use TIFFs?
Are all images embedded in final file?
Can I understand images without reading the legend?
All annotations should ideally be labeled with a white font.

https://drive.google.com/open?id=1Nev0KPxjwJWUv_4hB_mSkR6axf8fNL36


Introduction to this guide

Goals of this document (see blog post for more)
Illustrator is an extremely powerful tool for scientific figure creation but has significant cognitive burden for
someone just starting out. This is meant to be a fairly cursory beginner’s guide to the pieces of Illustrator you
require to be able to construct a scientific figure but should also impart the Adobe “lingo” needed to allow for
more specific queries. Additionally, within the How to’s section I have included some of what I feel to be the
most frequently asked questions, given my experiences thus far in lab.

Disclaimers:
● While this document will hopefully impart the tools and language to approach Illustrator for scientific

figure-making, it makes no claims or recommendations on aesthetic or design guidance.
● Illustrator is very expensive, and not everyone has access to it for scientific figure design. Numerous

people have recommended free (Gimp, Inkscape) or less expensive (Affinity Designer) alternatives;
while I cannot comment on those, I’ve been told that some of the shortcuts/overall concepts from this
document translate to Inkscape.

Why Illustrator...

Over figure-scripting?
Because it’s a lot of trouble to fully script figures, and hardcoding everything can make it very difficult to make
requested edits. Make sure to have MATLAB scripts for things like image contrasting and cropping, but use
Illustrator for things like:

● Resizing images/figures
● Adding scale bars
● Easily modifying colors and rearranging panels
● Easy aesthetic adjustments (i.e. alignment, compiling micrographs with schematics)

Over other Adobe softwares like Photoshop or InDesign?
Here’s a nice comparison of when to use which Adobe design software (i.e. Photoshop vs Illustrator vs
InDesign). Our figure design needs fall solidly into the Illustrator camp: a single page layout that can combine
raster images with punchy vector graphics and a small amount of text.

Over PowerPoint?
Powerpoint is largely designed to create presentations for screen resolution rather than print, leading to
decreased resolution for most figures. This is also why it sucks to attempt to convert a PowerPoint figure to an
Illustrator (or other) figure - the resolution of the initial image is generally lost. On the other hand, Illustrator is
designed to create vector graphics which, as discussed more below, have essentially infinite resolution
(whether used for tiny favicons or blown up to billboard proportions). Additionally, Illustrator is much more
flexible and powerful than PowerPoint (more editing capabilities and control).

http://rajlaboratory.blogspot.com/2019/08/i-adobe-illustrator-for-scientific.html
https://99designs.com/blog/tips/photoshop-vs-illustrator-vs-indesign/


Where can I find onboarding documents (Raj Lab only)?
Here is how to download Adobe Illustrator CC (Raj lab only). As noted in that document, be sure to sign up to
use one of the licenses. Save yourself some more hassle by immediately changing your default font from
Arjun’s most-hated Myriad Pro to Helvetica following these instructions - note that the template created in this
document should also give you the correct default document formatting as described below.

https://docs.google.com/document/d/1RbhkWTFOoefCJ72Rs6x2l6ympnlEdNqrdM0-Iema4Ro/edit?usp=drive_web&ouid=100242432562263142584
https://docs.google.com/spreadsheets/d/1sGgHt0wFQRC-uRVrQp3S8VdlFZIVZ7fcAVnuij9HdVU/edit#gid=0
https://docs.google.com/document/d/1LcUye8HJJv-9iDDjhlK6OxCrTkP8UFoux-ozXwMXDBE/edit


How to’s:

How do I find my document formatting settings?
Every time you start a new document in Illustrator, you should be able to find this information, i.e.

These are the defaults you should be using:
● Letter size artboard, configured in points
● Color mode RGB (not CMYK)
● Raster effects resolution high, i.e. 300ppi

But let’s say you’re in a document and you can’t remember how it’s configured: what do you do?

Artboards
On your main screen, click on the button marked “Document Setup” in the header bar. Click on the button
marked “Edit Artboards”. Looking back to where the “Document Setup” button was you should now notice
width (W) and height (H) measurements. Default 8.5x11-inch measurements are 612ptx792pt. To exit this
screen, click on any tool or use a keyboard shortcut (ex. “v” gives you the Selection tool, i.e. the filled-in arrow).

Color profile
Go to “File” and hover over “Document Color Mode”. You should see a checkmark next to RGB.

Raster effects
Go to “Effect” → “Document Raster Effects Settings”. Check that your resolution is toggled to “High (300ppi)”.



I want to import this graph/image/object into Illustrator: what should I know?

A couple guidelines for exporting graphs from R/MATLAB to Illustrator
❏ If exporting anything with dots: when you use ggsave, include the statement “useDingbats = F”

❏ Alternatively, install the font Adobe Pi - talk to Arjun
○ These dots (now text) can be expanded in Illustrator if you need to edit their object attributes

(ex. size): after selecting all the objects in question (you might want to use special select), go to
“Object” → “Expand”.

❏ Tick labels may not export properly (prepare to relabel axes in Illustrator)
❏ Check your font size against image size (i.e. sometimes when saving to SVG format from R, I’ve

noticed that the font is vastly larger than it was in the initial image - this may be because the font size is
constrained but the image size is much smaller?)

What types of files can Illustrator import and what should I know about them?
Typically, instruction manuals will have you import files by choosing “File” → “Place”. Note that if you select
“Link” your Illustrator document will link to the file; deselect link to embed the artwork in the document (more on
that here). Click where you want the image to go on your document. Note though that Illustrator can also
directly edit some of these files.

● Directly editable files:
○ Adobe Photoshop

■ If the file has layers, you can choose how to convert them.
■ If the file has layer comps, you can choose which version of the image to import.

○ Adobe PDF
■ If you choose a file with multiple pages, a dialog box will ask you which page you want to

place and how you want to crop the artwork.
■ This will probably come in with a bunch of white boxes/artifacts (any “transparent space’

ends up having its own box) that you will have to delete to access specifically the
graph/artwork.

● This can be done manually or potentially with a script (see this tweet for an
example).

○ Encapsulated PostScript (EPS)
■ All objects will be converted to native Illustrator objects, but anything that Illustrator

doesn’t recognize will be lost.
■ EPS format does not support transparency, so there may be many white boxes, and

what you thought were plain colored vectors may have white areas.
■ If you link instead of embedding EPS images, they will not be color-managed.

○ Scalable Vector Graphics (SVG)
■ XML-based vector format that describes images as shapes, paths, text, and filter effects.
■ Usually I try to use this format and edit it directly then copy-paste the area I want into my

Illustrator file.
● Files that you can really only edit with work and loss of some structure

○ Desktop Color Separation (DCS) is a version of standard EPS format but supports only CMYK
images. DCS files can be linked but not embedded or opened in Illustrator.

○ Bitmap image (GIF, JPEG, WBMP, PNG, TIFF) resolution is determined by the source file.
These files will have to be traced and expanded if you wish to edit them directly - unless they
are line art this might make your images wonky.

■ Side note: Here are some differences between these file formats.
Good general guidelines: Import all graphs and artwork as vectors/directly editable files (SVG, PDF). You
can, however, use Illustrator to convert line art to vector graphics if need be. Import all images (ex. microscopy)
as TIFFs.

https://twitter.com/davidhalat/status/1164592733920432128
https://www.widen.com/blog/whats-the-difference-between-png-jpeg-gif-and-tiff


What are layers, and why will I grow to love them?
Sometimes you create complicated things in Illustrator, and selecting specific objects becomes difficult. Layers
are one way to manage all of the items that contain your artwork - you can imagine that they are something like
very flexible clear folders. Artwork can be moved between layers, and layers containing artwork can be
reshuffled to change artwork stacking. Layers can be merged and can even contain sublayers. A real-life
example of why layers might be useful is in reconfiguring poster information to meet a new required poster
size: if each of your panels is in a different layer, you can easily select that whole panel and stretch/resize it to
fit, rather than painstakingly separating pieces of your poster from each other.

The layer panel has 6 sections:
A. Visibility column - Artwork in this layer is visible when the eye icon is present.
B. Edit column - Artwork in this layer is locked and will not be editable when the lock icon is present.
C. Color - This color (up to 9 unique) is automatically assigned to your layer and will display in the

illustration window as bounding box, path, anchor points, and center point of a selected object.
D. Small image of layer artwork and layer name (self-explanatory)
E. Target column - This might be a double or single ring depending on whether effects are being applied,

and honestly I never look at this. Clicking this target will select everything on that layer.
F. Selection column - A color box appears when an item on this layer is selected. If everything on the layer

is selected, the color box becomes larger.

Note how one layer is hidden (column A) and so no objects from that layer appear (would be under subheading
C). One layer is locked (column B) - the “letters/guides” layer containing the subheading letters. The two visible
unlocked layers are the green “bursting” and red “response” layers (column C). You can see in the image that
the selected cell under subheading A is outlined in red, indicating that it is from the red “response” layer.
Similarly, all of the selected objects under subheading B are outlined in green, indicating that they are from the
green “bursting” layer. Although objects on two layers are selected, we can only be on one layer (i.e. if we were
to, say, paste an object now it would go into a single layer) - that layer is the highlighted one (here it is the
green “bursting” layer). The double ring in column E indicates that the green “bursting” layer is targeted. There
are squares in both layers with selections in column F: because everything in the green “bursting” layer is
selected, the square is larger.

Cool, you’ve convinced me. How do I add layers?
Look to the right panel in your Illustrator window for the tab labeled “Layers” (by default it’s sandwiched
between “Artboards” and “Libraries” on the bottom right. Once selected, click on the 3 horizontal lines to the
right of the tabs. Click “New Layer…”. You can name your layer in the pop-up (or rename later by
double-clicking the Layer name). By default, your layers will be numbered.



Things you might want to include on a locked background layer

›Margin guides
If you like smart guides (light cyan lines that run horizontally and vertically but do not appear in any print copy),
this might be an option for you. Start by bringing your ruler into view. You can do this one of two ways:

1. Use the keyboard shortcut “cmd+r”.
2. Go to “View” → “Rulers” → “Show Rulers”.

Now click on either the top or side ruler and drag out onto your artboard. You can measure these guides
against your rulers to create your margins OR WHAT I ADVISE is to while your guide is still selected go to your
“Transform” panel and set its relevant X or Y coordinate. (i.e. vertical lines should have X-coordinates of 36
and 576; horizontal lines should have Y-coordinates of 36 and 756).

Here, even though my margins are locked on the layer called “Background margins”, I can use them to resize
my image - the fuchsia “Guide” is evidence that the right side of the figure is aligned to the smart guide, i.e. the
margin. EDIT 2021: Illustrator actually has a built-in way of locking guides such that you need not actually store
them on a separate locked layer: go to “View” → “Guides” → “Lock Guides” (keyboard shortcut “opt+cmd+;”). I
usually keep them locked unless I need to edit them and otherwise store them on the same layer as my figure
headings/subheadings/legends).

Boxes (as for posters)
It’s my personal preference to have poster boxes on a background layer that I can lock and edit separately
from any of the poster contents, i.e.



TBH I do this with titles too and then keep box contents in separate layers too, but do what you want! Knock
yourself out! Layers are great!

How do I move objects between layers?
Oh no, you’ve put an object onto the wrong layer! Now what? Using the Selection tool, select all of the objects
you wish to move to your new layer. Without unselecting your object of interest, click on the layer you wish to
move to. Go to “Object” → “Arrange” → “Send to Current Layer”.

What are some tricks and tips for aligning figures?
Meet your new best friend, the “Align” panel, generally found on the top right of your screen:

Align and Distribute
Alignment: Objects can be aligned with respect to an anchor
(which can be 1 or more other objects or the page).

● Horizontal alignment: match left sides, right sides, or
centers of objects that are stacked on top of each other.
Can also use to center object on page (toggle in “Align To”
menu in bottom right.

● Vertical alignment: match top or bottom sides or match
middles of objects that are next to each other. Can also use
to move object midway down the page.

Distribution: Allows even spacing of objects in horizontal or vertical direction based on some criteria. Will
automatically distribute objects between two objects at the extremes.

● Horizontal distribution: Evenly space left sides, centers, or right sides, based on the leftmost and
rightmost objects. Ex. if using “right-distribute” (far-right button on panel), the rightmost edges of all
selected objects will be used to determine distribution bounds.



● Vertical distribution: Evenly space bottoms, centers, or tops of objects, based on top and bottom
objects.

● “Distribute Spacing” options (bottom left buttons) allow horizontal and vertical distribution not with
respect to each other but with uniform gaps between objects.

○ These buttons are very useful if, for instance, you decide to make the (questionable) decision to
create a table in Illustrator and need to make sure boxes abut each other.

Align to key objects
● If you want to specifically align object B to object A (instead of aligning them to each other), after

selecting objects A and B, click again on object A (WITHOUT holding down “shift”) to designate it as
your “key object”. Then select the type of alignment you want to do.

How do I “paste in place”?
Using the typical shortcut for paste “cmd+v” in Illustrator will send your pasted object anywhere in the artboard.
If, instead, you want the pasted object to go to the same place as the initial object (this is useful, for instance, if
you want to start a new figure but make sure your titles and captions are in the same place as before), you
should instead “paste in place”. You can do this in at least 2 ways:

1. Use the keyboard shortcut “cmd+shift+v”.
2. Go to “Edit” → “Paste in Place”.

Also of note, you can also use “Paste in Front” (“cmd+f”) or “Paste in Back” (“cmd+b”) to designate pasted
object arrangement with respect to other objects on the artboard.

Some general alignment guidelines?
● All related graphs should be the same size and should be both aligned (center + middle) and distributed

evenly across their section of the page.
● Numbering on y-axes should be right-aligned and accurately/evenly spaced.
● Axes name labels should (usually) be center-aligned with their pertinent axes
● Try to square off your figures
● Center figure captions to page (i.e. Click on the grid under “Align To” then “Align to Artboard”, and then

select the middle horizontal align button).
● Use your best aesthetic judgment.

How do I change my arrow key increment from the default?
By default, the arrow key increment distance is 1 point (1/72 of an inch ~ 0.3528mm). You can change this (I
like to make it smaller) by going to “Illustrator” → “Preferences” → “General”. Change your “Keyboard
Increment” preference.

Vector graphics: drawing, making, editing
Vector graphics are made up of lines and curves and describe images according to their geometric
characteristics. They are resolution-independent and thus are great for things like schematics and logos.

About paths
Essentially every vector graphic is composed of paths, which are made up of
one or more straight or curved segments. Each segment is bracketed by
anchor points (marked in Illustrator by unfilled or solid small squares). When

using the Pen tool , every time you click, you lay down a new anchor
point. Paths can be closed (ex. Shapes, Paths 2 and 3 below) or open with



distinct endpoints (ex. Line, Path 1 below). The shape of a path can be changed by dragging at any of its
components:

For example:
● A: Unselected (unfilled) corner anchor point
● B: Selected (solid) smooth anchor point
● C: Curved path segment
● D: Direction line = tangent to the curve at the anchor point

○ Angle of line determines slope of curve
○ Length of line determines height/depth of curve

● E: Direction point - use to move/resize direction line

Anchor points: 2 types
1. At a “corner point” (ex. A), the path abruptly changes direction.

a. A corner point may have 0, 1, or 2 direction lines, depending on whether it joins 0, 1, or 2 curved
segments; these direction lines move independently of one another.

2. At a “smooth point” (ex. B), path segments are connected as a continuous curve (i.e. connects 2 curved
segments).

a. Each smooth point has 2 direction lines which move as a single straight unit.

Change between point types using the buttons found in the header bar: . The left button will
convert smooth anchor points to corner anchor points, and the right will convert corner to smooth.

Add or subtract anchor points to a path using the “Add Anchor Point tool” (keyboard shortcut “+”) and the

“Subtract Anchor Point tool” (keyboard shortcut “-”), by default hidden behind the pen tool.

The path outline, made up of multiple connected anchor points, is called a “stroke”, and can be assigned a
weight, dash pattern, and a color. Any color or gradient applied to an open or closed path’s interior area is
called a “fill”. Each path also contains a “center point” which corresponds to the center of the object but is not
actually part of the path (and thus cannot be deleted) - you can use this point to select all anchor points on the
path, move the entire path without distortion, or align the path with other elements.

Selection tools in Illustrator: how should I click on my object/part of object of interest?

“Selection tool” : keyboard shortcut “v”
This is by default the very first toolbar icon and probably should be. When using the Selection tool, you can
select entire objects or groups by clicking; i.e., you will activate all anchor points in an object/group at the same
time, such that you can move your selection without changing its shape. This is generally the tool to use if you
want to move an object, resize a group of objects, etc. You can select objects in 2 main ways:

1. Click on any part of the object or group. Unlike with the Direct Selection tool, it does not matter whether
you click within the object, along the path, or at a single anchor point. You can hold “shift” and click to
select multiple unrelated objects.

2. Drag a marquee around part or all of the object or group.



When using the Selection tool, you will always see a rectangular bounding box around the selected object(s).
For example: all of the “cells” in this frame are grouped, and so by clicking on any one cell using the Selection
tool, all of them are selected.

“Direct Selection tool” : keyboard shortcut “a”
Found directly under or to the right of the Selection tool, this white arrow allows for the selection/modification of
paths *within* shapes. Use this tool to:

● Select a single object within a group (by clicking in the center of that object). Note that unlike when you
are using the Selection tool, the bounding outline is limited to the outline of the object(s) selected.

○ With that object selected, even if you change to using the Selection tool, it will still keep just that
one part of the group selected.

○ As with the Selection tool, you can hold “shift” and click on multiple objects or points within a
group or draw a marquee around a portion of a group.

● Within a path, modify a specific anchor point or edge. You can selectively move/drag part of an object to
distort the initial shape or, if altering a curved path, use direction points to change the degree of
curvature at the selected point.



Other selection tools

● Group Selection tool : Hidden in the Direct Selection tool (click and hold down to reveal), this tool
adds grouped items as you use it to click objects. I don’t use it much but maybe you will like it.

● Magic Wand : Used to select objects with like appearance attributes (ex. Fill and stroke colors).
See more below.

● Lasso : Also hidden in the Direct Selection tool, you can use the Lasso to click and drag around
anchor points you want to select (useful if drawing a rectangle around them is unfeasible).

How do I set stroke weight?
Draw a line segment or use the Selection tool to select the line that you wish to alter. In the header bar towards
the left after color selections is the stroke weight information. You can choose a stroke weight from the
dropdown or enter your preferred stroke weight directly in the box. Generally, use 0.5pt for most lines in
figures; the main exception are arrows which can have a larger stroke weight.

Note that stroke weight will increase proportionally if/when graphic is resized and may have to be readjusted at
the end!

I have made axes or some other object with right angles but now it looks like there is a
gap at the corner: how can I fix this?
Using the Selection tool, select only the vertical or horizontal line(s): i.e. if you are altering a single graph axis,
choose only the X or Y axis. On the right-hand panel, find the “Stroke” tab - by default, it is next to “Gradient” in
the second set of panels from the top. Where there are options for “Cap”, select the rightmost option
(“Projecting Cap”).

I added a line segment but I want it to be dashed/dotted: what do I do?
With the Selection tool, select your line segment. On the right-hand panel, find the “Stroke” tab - by default, it is
next to “Gradient” in the second set of panels from the top. Next to “Dashed Line” is a checkbox: click it. If you
want a simple homogenous dashed line, change the first dash value to your desired dash width. Change the



gap value to your desired gap width (default = 12pt). Have a field day playing with different patterns you can
make this way but actually probably don’t do that for scientific figures it’s prob not the time.

I added a line segment but I want an arrow: what now?
With the Selection tool, select your line segment. On the right-hand panel, find the “Stroke” tab - by default, it is
next to “Gradient” in the second set of panels from the top. If you do not see any options related to
“Arrowheads”, click on the 3 horizontal bars to the far right of the panel tabs and select “Show options”. Next to
“Arrowheads” you will see the two ends of your line segment delineated. Change the relevant end (you only
have 2 choices just guess and change it if wrong) to an arrowhead - Arjun’s preference seems to be Arrow 5.

My arrowhead by default is ridiculously big when I use my desired stroke weight. How
do I change it?
Navigate once again to the Stroke panel (see above for more details) and make sure you can see options
related to “Arrowheads”. Under your arrowhead, you should see options for “Scale”. Change this scale amount
to like 50% or whatever seems aesthetically preferable. Your arrowhead endpoint will remain the same (line
segment is the same length).

Some notes on transform tools in Illustrator
There are many ways to transform artwork in Illustrator; some will be covered in the section below on resizing
groups of images. Here is a mishmash of other notes on transforming:

● For any of the below transform tools, you select multiple objects at once, by default the transformation
will be applied to all of the objects together around a single reference point. To simultaneously
transform multiple objects individually (ex. Let’s say you want to shrink every bar in a graph without
affecting the spacing between bars), go to “Object” → “Transform” → “Transform Each” (keyboard
shortcut “cmd+option+shift+D”). A dialog box will pop up allowing you to scale objects, move them
horizontally or vertically, and/or rotate them at a specific angle.

● Strokes and effects are by default not scaled along with objects. To scale them, choose “Illustrator” →
“Preferences” → “General” → “Scale Strokes & Effects”

● It is sometimes useful to change your reference point (i.e. the part of your object that is anchored to the
artboard while the rest of your object transforms). One way to do this is by looking within the transform

dialogue for the reference point locator (default is object center) and selecting your point of choice.
Here is an example: in the left image upon changing the width the object expands outward from the
center reference point such that the white and blue boxes are no longer abutting. In the right image, the
object expands outward from the right edge reference point, maintaining the border between boxes.

vs

Scale
● Objects can be scaled by a percentage using the Scale dialog box (“Object” → “Transform” → “Scale”).



Rotation
● Objects can be rotated using the bounding box: Using the Selection tool, move the pointer near a

bounding box handle until the pointer changes to and then drag. If you hold “shift” while dragging, it
will constrain the rotation to multiples of 45º.

● To rotate around the center point by a specific angle, choose “Object” → “Transform” → “Rotate” or
enter an angle in the Transform panel.

● To rotate around a different reference point, select the Rotate tool and click to reposition the
reference point.

● To rotate a copy of the object, select the Rotate tool then hold “option” after you start to drag.

Reflection

● Reflect across any axis using the Reflect tool (may be hidden initially: follow instructions as for
Magic Wand). Use the Selection or Direct Selection tool to select the object(s) you want to reflect. Click
on the Reflect tool. Click any 2 points to define the axis: the selected object should flip over that defined
axis. To reflect a copy of that image, hold down “option” before clicking the second point.

Moving
● As mentioned elsewhere in the document, you can move objects by clicking+dragging as well as by

setting X and Y coordinates in the Transform panel.
● Moving objects with arrow keys: Default distance is 1pt (1/72 inch ~ 0.3528mm). To change the

Keyboard Increment preference, go to “Illustrator” → “Preferences” → “General”
○ “Shift+arrow” will move the object 10x your Keyboard Increment

● To move object by a specific distance, choose “Object” → “Transform” → “Move” and enter your desired
move distance.

○ You can also use this to specifically move the object pattern rather than the object itself.

I have TOO MANY POINTS and it is killing my Illustrator - HELP.
Sometimes when you have too many points in a graph, it can increase your document size to a point where it
slows down your Illustrator. First try saving and quitting, then reopening (sometimes will make it workable).
Else, continue with these instructions.

With the Selection tool, select your object that has too many points. Go to “Object” → “Rasterize…”. This will
turn that vector object into an uneditable image. Save your document with a new name (ex. Append “raster” to
the original name). This document should be much more editable but make sure to double-check the rasterized
image to make sure it is what you want it to be before submitting (can always replace with the original object
when fewer edits are made before rasterizing again at the very end).

Notably, Ben noticed that this may also occur if you saved a plot from R as a PDF without Lauren’s tip (see
comment above in this section, which will save you from having to do the following) wherein each geom_point
is composed of a point and a doughnut outline (of the same color) around that point that look as though they
are a single larger point but are indeed two separate elements. In this case, it may help if you select one of
these doughnut points, select all objects with the same stroke weight, and delete them. Following this, select
all the remaining points (can try to do this using fill color or some other method) and click “Expand” in the top
banner (as they may be loaded as “text” objects which will not respond properly to any attempted
transformations).

https://twitter.com/BenEmert
https://twitter.com/laurenbeck131


I have a line art drawing that I want to vectorize! How can I do this?
While there are many ways you can use Illustrator to draw, it may
never be as intuitive as drawing with pen on paper or stylus on
tablet. Let’s say you sketch out a cell or other object that you want to
incorporate into your Illustrator schematic. For instance, here to the
right are some cells that I drew using a tablet, saved in PNG form.

How can I make them vector images, with editable stroke weights
and color fill? Begin by either placing your image in an already open
Illustrator file or by right-clicking the PNG (or JPEG or what have
you) and selecting Illustrator from the “Open with” dialogue. Feel
free to transform your image to a size that makes sense for your
artboard. Using the Selection tool, click on your image. In the
header bar, you will see a button that says Image Trace with an arrow to its right: click on that arrow tov reveal
your trace options.

If you have a more complex image that you wish to vectorize (for example one that you have pre-colored) you
can try using the “16 Colors” option. Else for something like the sketch I’ve shown here, the “Line Art” option is
the cleanest. Once your image is traced (note here how the lines became darker and clearer, and gaps
appeared), click the “Expand” button in the header bar to convert your traced object into paths.



Now the expanded image should be fully vectorized (fully composed of paths as described above).

By default, this entire drawing is grouped as a single object. One way to separate, say, a single one of these
cells (i.e. part of the drawing) for editing is to use either the Direct Select or Lasso tool to select the desired
portion and then copy-paste: the resulting paths within your selection will all ungroup. For example, I am now
able to use the Selection tool on just the rightmost cell, but unless I group the nucleus to the cell body, those
paths will move separately from each other. Moreover, since there are gaps in the cell outline, all those pieces
will also separate unless you patch them first.



If you plan to try and color fill your objects at some point, this is a good time to go through and close any gaps.
Use the Direct Selection tool to select two adjacent separate points on either side of the gap (see left image)
and use the keyboard “cmd+j” to join your two anchor points (see right image).

Type/text
Before you begin, remember that your default font should be Helvetica (or something equally legible). Go here
to see how to change your default font.

What font am I using? How do I change it?
Using the Selection tool, click on the relevant text on your screen. You will see that on the header bar,
“Character” appears: click on it to bring up the Character panel. You can use the dropdown menus to change
fonts and sizes, and even distort your font by stretching/squeezing letters, altering kerning, setting type
leading, etc.

● These distortion parameters are useful for saving your labels if you have them in point type (see next
section) and accidentally stretch them. Reset your horizontal and vertical aspect ratios to 100%.

https://docs.google.com/document/d/1LcUye8HJJv-9iDDjhlK6OxCrTkP8UFoux-ozXwMXDBE/edit


Point type vs area/paragraph type: what’s the difference?

Point type: what Arjun calls “text”:
If you select the Type tool and click on your artboard, you are entering “point type”. Point
type is a horizontal or vertical line of text that will begin upon your click and expand as
you add characters; it will not text-wrap. If you try to edit this text by stretching the edges
of the text box, the characters will distort (see above for how to fix this distortion). Point
type can be rotated to track along a given shape/curve.

● Use point type for adding a few words to figures (ex. Labels, short titles).

Area type: what Arjun calls “text box”:
If after selecting the Type tool, you click and drag diagonally to define a rectangle, you are
entering “area type”, also called “paragraph type”. Area type will use the boundaries of
the defined object to control horizontal or vertical flow of characters (cannot be anything
except horizontal and vertical - if rotated, the text will remain horizontal or vertical even as
the text box moves). When text reaches a boundary, it will automatically wrap to stay
inside the defined area. Similarly, resizing the text box will shift the arrangement of the text but will not distort
characters.

● Use area type for figure captions.

In Adobe Illustrator CC 2019, you can double-click on the circular handle that appears on the right side of your
text box to switch it between point and area type.

How do I superscript or subscript?
Highlight the text you wish to superscript or subscript. Click on “Character” to access the Character panel. At
the bottom of this panel you will see buttons for superscript and subscript.

How do I change the formatting of my text, ex. for figure captions?
Use the Selection or Type tools to select the text whose formatting you wish to edit. Click on “Paragraph” to
access the Paragraph panel. Here you can control paragraph formatting (ex. Change default left-aligned text to
left-justified or full-justified). You can also use the left and right indent dropdowns to control text box side
padding.

For some reason, I want to add bullet points/numbering in Illustrator
There is no direct way to do this in Illustrator because it is not a word processing or presentation software.
Here is a workaround:

1. Place all of the text you wish to be bulleted or numbered in its own (area) text box.
2. Click “Paragraph” to open the Paragraph panel.
3. Add the font size pt value to the left indent value (first dropdown - see name upon mouseover).
4. Enter the negative value of the font size pt value as the first-line left indent (immediately below left

indent value).

A very brief overview of colors
Every object in Illustrator can be assigned a Fill color and a Stroke color (note that lines will only ever display
their Stroke color even if a Fill color is assigned). This can be visualized in multiple places on your screen
(scroll to see image). I usually toggle colors based on the bottom left squares. Note that whichever one is in



front is the editable color. You can toggle between with the keyboard shortcut “x” or by clicking the back square
to bring it to the foreground.

These days, all journals seem to like RGB mode for colors instead of CMYK. Which is better (for screen
viewing) anyway, since CMYK can’t produce all the colors that RGB can. Note though that anything you mean
to print will be more accurately visualized with CMYK (some more details below).

How do I edit colors?
There are so many ways to do this but here are a few options.

1. Use Swatches: Go to the “Swatches tab” (third panel down on your right-sided default grouping of
panels, next to “Color” and “Color Guide”). If the color you want is a swatch here, you can just click on
it. You can also load swatches (bottom left of this panel there is a button that looks like a few vertical
books: mouseover says “Swatch Libraries menu”) or if you have a color that is not swatched, you can
make a swatch by simply clicking that color and dragging it over to your swatches menu.

2. Click on the “Color” tab to open the Color panel. You can select any color using RGB values, HEX
code, or navigating the RGB spectrum.

3. Double-click on the square whose color you would like to edit to get the “Color Picker” menu. This looks
a lot like the Color panel but also allows you to narrow your selection to just web-supported colors, use
CMYK adjustments, alter hue (H), saturation (S), and brightness (B), and compare your new color to
the object’s current color.



I want to match the color of an image I have already: how do I do that?

One way to copy appearance attributes is to use the Eyedropper tool . By default, the Eyedropper tool will
copy any and all attributes of a selection (i.e. fill color, stroke color, character, paragraph, etc.). Start by using
the Selection or Direct Selection tool to select the object whose attributes (ex. fill color, stroke color, etc.) you
want to change. Click on the Eyedropper tool. Move the eyedropper tool to the object whose attributes you
want to copy and do one of the following:

1. Click on it: this will sample all appearance attributes and apply them to the selected object.
2. “Shift”+click to sample only the color from a portion of a gradient, pattern, placed image, etc. and apply

the color to the fill or stroke (whichever is the top square).
3. Hold “shift+option”+click to add appearance attributes of the new object to the selected object’s existing

attributes.

Note: the Eyedropper tool can actually also sample RGB colors from outside the document (will become fill vs
stroke color depending on which square is in front).

Additionally, you can edit which appearance attributes can be sampled using the Eyedropper tool by
double-clicking it and selecting off of the pop-up.

I want to recolor/edit everything that is of one color/attribute: how?
There are a couple ways that you can select everything of a certain type:

1. Use the Selection tool to click on an object that has a feature of interest. Go to “Select” → “Same” →
and then choose whichever attribute you’re interested in. This will use the most stringent settings (must
be the exact same fill color or stroke color or opacity or etc.). Note also that this may be limited by
object “groups” (i.e. you may experience difficulties selecting only a portion of a grouped object).

2. The Magic Wand tool is useful for selecting objects of the same or *similar* attributes. What this
means is that you can set a tolerance such that if you want to select every object that has a pinkish fill
color, you might set a Fill color tolerance of, say, 20. Alternatively, if you only want one very specific
shade of pink (and/or you want to avoid editing other objects that are of a similar yet different color),
you can set a tolerance of 0. To bring up the Magic Wand menu, go to “Window” → “Magic Wand”. If the
Magic Wand is not in your toolset, click on the 3 dots on the bottom of the left side toolbar, and drag the
Magic Wand into place.

Illustrator soft-proofing tools for simulating how images will appear to others
Soft-proofing features allow you to simulate on your computer monitor how images might appear on other
devices (ex. upon printing). For example, since CMYK (common for print design) cannot produce all of the
colors that RGB (web design) can, sometimes images look worse or simply different upon switching between
color modes (ex. when printing).

For example, here is the same image in CMYK (left) vs in RGB (right).



(CMYK) vs. (RGB)

To see how an RGB document might look in other profiles, go to “View” → “Proof Setup”, and select your
desired option.

Using these tools to simulate how images will look to people with color blindness
While figure and color design are outside of the scope of this guide, I’d be remiss if I didn’t mention Illustrator’s
soft-proofing features that allow for color blindness simulation (thanks Karun for the suggestion). Here, for
instance, is a palette that I created based on a poster I found by Krzywinski et al.:

Now, if I go to “View” → “Proof Setup” → “Color blindness - Protanopia-type” (blindness to red):

https://twitter.com/MrKarunhands
http://mkweb.bcgsc.ca/biovis2012/


Similarly, “View” → “Proof Setup” -- “Color blindness - Deuteranopia-type” (blindness to green) gives:

Images
Reminder: Never contrast or crop images in Illustrator!!

How do I add a scale bar?
Use the line segment tool with stroke weight 3pt and stroke color white to draw a horizontal line on your image.
Calculate (examples below, courtesy of Ben) what 5 or 10 microns should be in points, given the
#microns/pixel (specific to camera), camera magnification, imaging binning, cropping, and image resizing in

https://twitter.com/BenEmert


Illustrator. In the header menu, click on Transform to alter the width (W) of the line segment to correspond to
the correct point value for 5 or 10 (or whatever is reasonable) microns.

● Here is a helpful blog post from Gal about calculating Image pixel size: In brief:
𝐼𝑚𝑎𝑔𝑒 𝑝𝑖𝑥𝑒𝑙 𝑠𝑖𝑧𝑒 =  𝑐𝑎𝑚𝑒𝑟𝑎 𝑝𝑖𝑥𝑒𝑙 𝑠𝑖𝑧𝑒 *  𝑏𝑖𝑛𝑛𝑖𝑛𝑔 / 𝑜𝑏𝑗𝑒𝑐𝑡𝑖𝑣𝑒 𝑚𝑎𝑔𝑛𝑖𝑓𝑖𝑐𝑎𝑡𝑖𝑜𝑛 *  𝑙𝑒𝑛𝑠 𝑚𝑎𝑔𝑛𝑖𝑓𝑖𝑐𝑎𝑡𝑖𝑜𝑛 *  𝐶 𝑚𝑜𝑢𝑛

● Our old Pixis cameras have 13 microns per pixel and 1024 x 1024 pixels. For RNA FISH, we often
acquire 100x images, where each pixel corresponds to 0.13 microns per pixel.

○ Thus, for a 1024 x 1024 image acquired at 100x without binning or cropping, solve the following
to determine the length of your scale bar:
𝑆𝑐𝑎𝑙𝑒 𝑏𝑎𝑟 𝑝𝑜𝑖𝑛𝑡𝑠 𝑖𝑛 𝑖𝑙𝑙𝑢𝑠𝑡𝑟𝑎𝑡𝑜𝑟

𝐼𝑚𝑎𝑔𝑒 𝑤𝑖𝑑𝑡ℎ 𝑖𝑛 𝑖𝑙𝑙𝑢𝑠𝑡𝑟𝑎𝑡𝑜𝑟 = 𝑑𝑒𝑠𝑖𝑟𝑒𝑑 𝑠𝑐𝑎𝑙𝑒 𝑏𝑎𝑟 𝑙𝑒𝑛𝑔𝑡ℎ (𝑒.𝑔. 10 𝑚𝑖𝑐𝑟𝑜𝑛𝑠)
𝑇𝑜𝑡𝑎𝑙 𝑙𝑒𝑛𝑔𝑡ℎ 𝑜𝑓 𝑖𝑚𝑎𝑔𝑒 (𝑒.𝑔. 1024 * 0.13 𝑚𝑖𝑐𝑟𝑜𝑛𝑠 𝑓𝑜𝑟 100𝑥 𝑜𝑏𝑗𝑒𝑐𝑡𝑖𝑣𝑒)

● Our new Flash 4.0 cameras have 6.5 microns per pixel and 2024 x 2028 pixels. For RNA FISH, we
typically acquire 60x or 100x images with 2 x 2 binning. For 60x this translates to 0.22um per pixel and
1022 x 1024 pixels per field of view.

○ Therefore, using our new camera set up, a 1022 x 1024 image acquired at 60x, the scale bar
length can be calculated by solving the following proportion:
𝑆𝑐𝑎𝑙𝑒 𝑏𝑎𝑟 𝑝𝑜𝑖𝑛𝑡𝑠 𝑖𝑛 𝑖𝑙𝑙𝑢𝑠𝑡𝑟𝑎𝑡𝑜𝑟

𝐼𝑚𝑎𝑔𝑒 𝑤𝑖𝑑𝑡ℎ 𝑖𝑛 𝑖𝑙𝑙𝑢𝑠𝑡𝑟𝑎𝑡𝑜𝑟 = 𝑑𝑒𝑠𝑖𝑟𝑒𝑑 𝑠𝑐𝑎𝑙𝑒 𝑏𝑎𝑟 𝑙𝑒𝑛𝑔𝑡ℎ (𝑒.𝑔. 10 𝑚𝑖𝑐𝑟𝑜𝑛𝑠)
𝑇𝑜𝑡𝑎𝑙 𝑙𝑒𝑛𝑔𝑡ℎ 𝑜𝑓 𝑖𝑚𝑎𝑔𝑒 (𝑒.𝑔. 1024 * 0.22 𝑚𝑖𝑐𝑟𝑜𝑛𝑠 𝑓𝑜𝑟 60𝑥 𝑜𝑏𝑗𝑒𝑐𝑡𝑖𝑣𝑒)

How do I resize groups of images?

Set W and H numerically when importing sets of similar images
Import images together by going to “File” → “Place” and then selecting all relevant images. Click “Place” and
then click on the artboard where you want each image to go (Illustrator will have you place each image
individually). Using the Selection or Direct Selection tools, select all images that should be the same size (hold
“shift” and click to select multiple images, or click+drag across images). Click “Transform” to open the
Transform panel:

This icon at the right (chain links) means that all width and height adjustments will be constrained to the same
proportions. If you wish to only stretch images in one direction, click on this icon to break the link. You can
enter in width and height values here as desired. Note that by default, images will be transformed individually
(i.e. spacing between images will not scale with resizing).

Resize images as a group
What if you want to resize a group of images such that they retain their distances to and proportions with each
other? This is when grouping objects can come in handy. Using the Selection or Direct Selection tools, select
all objects that you wish to transform together (either “shift”+click or click+drag) and group them, either using:

1. Keyboard shortcut “cmd+g”
2. “Object” → “Group”

*Note that if you group objects from different layers, the resulting group will be placed into the layer of the
topmost selected object. Groups can be nested.

Now whenever you use the Selection tool to select any piece of this group, the whole group will be selected -
all pieces will move and transform together. To resize proportionally, either:

1. Grab a corner bounding box handle of the group and while holding “shift” down, drag to resize.

https://greenfluorescentblog.wordpress.com/2013/01/10/calculating-the-pixel-sizes-on-images/


2. Go to the Transform panel and alter the width and height of the entire group.

What if I want to edit a piece of a group? Here are some options:
1. Use the Direct Selection tool (white arrow, keyboard shortcut “a”) to select a single object within a group

(click within the object) or a single anchor point or edge/path within an object.
2. Using the Selection tool, double-click the group to isolate the group. Click on the object of interest.

When finished, exit Isolation Mode by double-clicking anywhere outside the group, pressing “esc” or
“cmd”+click → “Exit Isolation Mode”).

3. Ungroup the objects.

To ungroup, you can either:
1. Keyboard shortcut “cmd+shift+g”
2. “Object” → “Ungroup”

Linked versus embedded images
When you place a graphic in an Illustrator document, a screen-resolution version of the file will be visible and
moveable, but it might be linked or embedded.

● Linked images are connected to but remain independent of the document: i.e., they do not factor into
the size of the document. These images can be transformed or modified by effects, but individual
components cannot be altered within Illustrator. If the original file is updated, links can be updated as
well to better reflect the new version of the image without re-placing it within the document. NOTE that
this also means that, if you move the original images (i.e. if the path is no longer the same due to, for
example, renaming of the folder or moving images to a new directory), Illustrator will no longer display
the images (you must re-link them, i.e. provide the new path, or embed them). These are also not
included by default when the document is saved and shared (Illustrator stores the original location of
the artwork) - if you would like to include linked files upon saving you must check the box “Include
Linked Files.

● Embedded images are copied into the document at full resolution and will increase the document size
(and, if large enough, may make Illustrator difficult to work with). The document is self-sufficient but will
not update if the original artwork file is changed.



How can I tell whether my images are linked or embedded?
While the image is selected, take a look at your header menu. All the way to the left, does it say “Linked File”
followed by the filename or “Image” followed by “Embedded”? For example:

vs.

Alternatively, you can also visit the Links panel (will also have more information). By default it is here:

If you can’t find it, go to “Window” → “Links”, and it should open. All embedded files will have a symbol to
the right of the link thumbnail. To view more information for a file, do one of the following equivalent things:

1. Double-click a link.
2. Click a link, then click the arrow to the bottom left of the panel (“Show Link Info”).

Next to “Format:” and the file type of the file, it will say whether the file is linked or embedded. Moreover, the
“Color space” and “Location” will only have value for linked files.

I’ve changed the original image file: how can I update my linked image?
To easily update a linked file, click the “update link” (cycle icon) in the Links panel.

How do I embed a linked image?
Why might you want to embed a linked image?

● You want to share the document with someone who may not have the linked image on their computer.
● This is the final version of your document, and you want it to be standalone.

In the header menu, there is a button called “Embed”. Click it.

How do I relink an embedded image?
Why might you want to relink an embedded image?

● Embedding the image makes Illustrator unusable, and you don’t want to rasterize it yet.



● You have changed the original image file and would like to update the image.
Here are a couple ways to do this:

1. In the header menu, click the “Unembed” button. This will trigger a pop-up where you can select the
original image file to relink to.

2. In the Links panel, click the small chain icon (mouseover “Relink). This will trigger the same pop-up
allowing you to select an image file to link to.

I’ve completed the checklist and Arjun likes the figures and now I’m
preparing to submit figures to a journal: what formatting do I need to do?

1. Embed all your linked images.
2. Rasterize all large images.
3. Save a copy of the file as a PDF using the following settings:

○ General: uncheck all options -- this is what will make the biggest difference in your file size,
especially if you have a lot of expanded plots and images (i.e. lots of memory needed to
preserve Illustrator editing capabilities).

○ Compression: Change all “Do Not Downsample” to “Bicubic Downsampling to 300ppi for images
above 300ppi”. Can also compress using ZIP.

4. Open the PDF in Adobe Pro DC. Go to “File” → “Save As…” (alternatively, “cmd+shift+s”) and check
the box that says “Reduce File Size”.

Works Consulted
While I have compiled this document, I owe most of my knowledge to trawling the internet for information. Here
are some sites (in addition to those cited above) that I consulted for this guide that may also be resources for
other things you would like to do. For everything else maybe just try Google and forums.

● Adobe Illustrator Learn & Support
● Dummies.com guide to Illustrator (includes older versions)
● Shutterstock support guides for Illustrator
● George Ornbo’s Illustrator guides

Some additional links that may be helpful
Disclaimer: I have not fully watched/vetted all of these, but they seem helpful for getting started with Illustrator.

● Illustrator CC Keyboard shortcuts in a nice diagram (Kudos to Eric for showing me)
● Dansky’s Illustrator Basics in 3 Minutes (and other videos)
● This well-reviewed Beginners Guide to Illustrator by Gareth David Studio
● Learn to draw Anything with Adobe Illustrator CC (gets a bit more graphic-designy but some helpful

techniques for if/when you want to make schematics in Illustrator)

https://helpx.adobe.com/support/illustrator.html
https://www.dummies.com/software/adobe/illustrator/
https://www.shutterstock.com/support/pkb_sstk_core_customerkb_home?q=adobe%20illustrator&l=en_US
https://shapeshed.com/tags/illustrator/
https://blog.designcrowd.com/article/984/best-keyboard-shortcuts-to-speed-you-up-in-illustrator
https://twitter.com/ErkSignal
https://www.youtube.com/watch?time_continue=4&v=M5jOg2iDPeM
https://www.youtube.com/playlist?list=PLYfCBK8IplO4X-jM1Rp43wAIdpP2XNGwP
https://www.youtube.com/watch?v=RbbQl2sU-ag

